QUESTION

asked by
Understanding M20048 Issues

Hello,

I am in the process of replacing a GPS module chip due to it not being manufactured anymore (M10478).

When looking at the data sheet for the M20048, it seemed to be an exact replacement for the M10478. However when I impliment4ed it into the circuit but, it seems to be stuck in this limbo mode. The Tx pin is output 1.2k Hz when I have the resistor arrangements to be outputting 9600hz.

Please log in or register to answer this question.

1 Answer

answered by

Hello Ntailor,

The module defaults to 9600 when E2 and E3 at not connected as per the datasheet in section 10.1:

The circuit below shows a basic design for use with the UART interface and

configuring the default baud rate to 9600. (NC on E2 and E3)

Also, the M20048 is software configurable through UART for the baud rate as per section 9.2 in the datasheet:

The UART converts bytes of data to and from asynchronous start-stop bit

streams as binary electrical impulses. The port contains a 16-byte FIFO, and

256 bytes of URAM. The baud rates are selectable from 4800, 9600, 38400

and 115200 bps.

The IO level from the UART port are CMOS compatible, however for RS232

compatibility the use of external level shifters will be required. The hardware

configuration of the port baud rate can be changed dynamically by the use

of commands. These will be active and saved as long as the BV supply is

applied.

Please let me know if you have any further questions.

Best regards,

Geoff S.

commented by
Good Moring Geoff,
Thanks for the clarification, I did notice that I made the mistake with the resistor configuration. I did fix that and the M20048 is outputting the correct baud rate.
I had a question about the FIX pin on this module, looking at the DATA sheet it didn't give much information on the pin. Will this pin just be a constant HIGH when a signal is found?
commented by
Hi Ntailor,

The FIX pin is pulled high when a fix happens and will remain high.

Best regards,

Geoff S.
commented by
Got it, Thanks.

Another issue I'm running into is the module wont lock onto a signal. When ever it sends the messages to the MCU they are invalid. Has this been an issue in the past? Is the antenna not strong enough?
Note: I was testing outside on a clear day, and let it run for about an hour. Did not lock onto any signals.
commented by
Hi Ntailor,

It sounds like the antenna needs to be tuned for the PCB it has been soldered to. What are your AT1 and AT2 values?

Best regards,

Geoff S.
commented by
Geoff,

What values are you looking for?

The Frequency is not constant it fluctuates between 33MHz to 2GHz (which doesn't seem right at all).

The Voltage is in the mV also.
commented by

The two components are placed at the top of the module and connect to ground on your PCB:

These two components set the antenna that is integrated onto the module on the proper GPS frequency in order to receive the GPS signal. The frequency I am referring to is the resonant frequency of the on-board GPS antenna. 

The module typically uses 3.3V for VCC.  It normally draws 24.5mA of current when it is acquiring signal from the satellites.

Best regards,

Geoff S.

Meet the moderators

Geoff Schulteis

Senior Antenna Apps Specialist at Antenova Geoff is an antenna design-in and OTA measurement specialist. His knowledge of FCC and world carrier requirements is second-to-none.

Steve Bradburn

Senior Antenna Engineer at Antenova With over 25 years’ experience in manufacturing, test and design, Steve has a wealth of RF and measurement knowledge across many industry sectors.

Yu Kai Yeung

Antenna Engineer at Antenova Yu Kai is an antenna expert with over 10 years of experience in the design and testing of antennas. He has experience helping customers with certification testing, combined with his knowledge of RF measurement procedures.

download-guide-image

Antennas: The Comparison Guide

Find the perfect antenna for your project

Download
...